Note, as of 2/11, a new version is available http://www.java.net/download/jdk6/6u14/promoted/b01/binaries/jdk-6u14-ea-bin-b01-linux-amd64-03_feb_2009-rpm.bin . See https://jdk6.dev.java.net/6uNea.html for details.

The difference between the rest of the note below is that the 64 bit plugin is now part of the JDK, whereas in 6u12 it was only available in JRE (?). Since JDK with the 64 bit plugin s actually what i want installed, I don't need to install a separate JRE. Progress.

However, the same problem from the note below persists in JDK6u14: the RPM either doesn't remove the prexisting symlink I made to /usr/lib64/mozilla/plugins/libjavaplugin.so or it doesn't try to create it in the first place. I believe the latter is still the case.

Therefore do the following steps:

wget http://www.java.net/download/jdk6/6u14/promoted/b01/binaries/jdk-6u14-ea-bin-b01-linux-amd64-03_feb_2009-rpm.bin
chmod a+rx jdk-6u14-ea-bin-b01-linux-amd64-03_feb_2009-rpm.bin
./jdk-6u14-ea-bin-b01-linux-amd64-03_feb_2009-rpm.bin
rm sun-javadb-*
remove other installs:
     sudo rpm -e jdk-1.6.0_11-fcs.x86_64       ##You may have some other java(s) installed
     sudo rpm -e jre-1.6.0_12-ea.x86_64
     sudo rm /usr/lib64/mozilla/plugins/libjavaplugin.so
sudo rpm -ivh jdk-6u14-ea-linux-amd64.rpm
sudo ln -s /usr/java/jdk1.6.0_14/jre/lib/amd64/libnpjp2.so /usr/lib64/mozilla/plugins/libjavaplugin.so

In order to do a combination of Java Development and Use 64 bit Java in Firefox, I did the following:

  1. JDK 6u11 has no moz plugin:: Install the RPM from Sun with rpm -ivh jdk-6u11-linux-amd64.rpm
  2. Sun's "early access" JRE jre-6u12-ea-bin-b03-linux-amd64 has a supposedly working 64 bit moz plugin.
However, #2 didn't actually work for me on Fedora 10 (2.6.27.9-159.fc10.x86_64 #1 SMP Tue Dec 16 14:47:52 EST 2008 x86_64). The RPM installed the wrong plugin /usr/java/jre1.6.0_12/lib/amd64/libjavaplugin_jni.so in the non-64 bit plugin location /usr/lib/mozilla/plugins … I deleted the bogus symlink to ensure a 64 bit Java running in Mozilla.

Finding http://pack.suse.cz/mvyskocil/sun_java_u12_howto on google suggested that the correct plugin is

lib/amd64/libnpjp2.so .

Therefore, for fedora 10 you need to make a symlink from:

/usr/lib64/mozilla/plugins/libjavaplugin.so -> /usr/java/jre1.6.0_12/lib/amd64/libnpjp2.so

And delete any other references to 32 bit java plugins in  /usr/lib/mozilla/plugins .

After restarting firefox, about:plugins shows

File name: libnpjp2.so

MIME Type     Description     Suffixes     Enabled
application/x-java-vm     Java         Yes
application/x-java-applet     Java         Yes
application/x-java-applet;version=1.1     Java         Yes
application/x-java-applet;version=1.1.1     Java         Yes
application/x-java-applet;version=1.1.2     Java         Yes
application/x-java-applet;version=1.1.3     Java         Yes
application/x-java-applet;version=1.2     Java         Yes
application/x-java-applet;version=1.2.1     Java         Yes
application/x-java-applet;version=1.2.2     Java         Yes
application/x-java-applet;version=1.3     Java         Yes
application/x-java-applet;version=1.3.1     Java         Yes
application/x-java-applet;version=1.4     Java         Yes
application/x-java-applet;version=1.4.1     Java         Yes
application/x-java-applet;version=1.4.2     Java         Yes
application/x-java-applet;version=1.5     Java         Yes
application/x-java-applet;version=1.6     Java         Yes
application/x-java-applet;jpi-version=1.6.0_12     Java         Yes
application/x-java-bean     Java         Yes
application/x-java-bean;version=1.1     Java         Yes
application/x-java-bean;version=1.1.1     Java         Yes
application/x-java-bean;version=1.1.2     Java         Yes
application/x-java-bean;version=1.1.3     Java         Yes
application/x-java-bean;version=1.2     Java         Yes
application/x-java-bean;version=1.2.1     Java         Yes
application/x-java-bean;version=1.2.2     Java         Yes
application/x-java-bean;version=1.3     Java         Yes
application/x-java-bean;version=1.3.1     Java         Yes
application/x-java-bean;version=1.4     Java         Yes
application/x-java-bean;version=1.4.1     Java         Yes
application/x-java-bean;version=1.4.2     Java         Yes
application/x-java-bean;version=1.5     Java         Yes
application/x-java-bean;version=1.6     Java         Yes
application/x-java-bean;jpi-version=1.6.0_12
last modified by Niels Mayer on Mar 09, 2009 10:50:52 GMT-08:00

Creator: Niels Mayer on Jan 20, 2009 17:03:04 GMT-08:00
This wiki is licensed under a Creative Commons 2.0 license
XWiki Enterprise 1.8.17790 - Documentation